[み]WordPressをエックスサーバーに移転したら謎のエラーが出たので、その原因と対処法

みはら.comのサーバーを、1年目は100円のドメインキングから、安定感バツグンで人気のエックスサーバーに移転しました。

こんなエラーがでました

WordPressの移転に関しては、これまでにもたくさんの方がわかりやすい記事を書いてくださっているので割愛しますが、実際にサーバーを移転してみたらこんなエラーがでました。

繧オ繝シ繝舌�縺ョ PHP 繝舌�繧ク繝ァ繝ウ縺ッ 5.1.6 縺ァ縺吶′ WordPress 3.5.2 縺ッ 5.2.4 莉・荳翫�縺ソ縺ァ縺泌茜逕ィ縺ォ縺ェ繧後∪縺吶

文字化けしていて何のことか一瞬わからなかったんですが、「PHP」と「WordPress」ってのだけはわかりますね。あとは、数字も文字化けせずに表示されているのでわかります。もちろん、何の数字なのかはわかりませんが…

エラーの原因

何のエラーなのかそのときは見当もつかなかったので、まずは、そのままコピペしてGoogle先生に聞いてみました。が、いまいちピンとこなかったので、わかっている「PHP・WordPress・5.1.6・3.5.2・5.2.4」で検索してみたら、エラーの原因がわかりました。

PHPのバージョンが原因でした。「WordPress 3.5.2では、PHP バージョン5.2.4以上が必要だけれど、このサーバーのPHPは5.1.6ですよ」っていうエラーだったようです。エックスサーバーで設定したときに、どうしてPHP 5.1.6になってしまっていたのかは不明ですが…

このエラーの対処法

PHPのバージョンが問題だったので、素直にPHPのバージョンをエックスサーバー推奨の5.3.3に切り替えたら、無事に表示されました。あっさり解決です。

解決していないことは、どうしてPHPのバージョンが5.1.6になっていたのかということだけですね… おそらく寝ぼけながら設定したので、単純にミスったんでしょうね…

シェアありがとうございます

  • このエントリーをはてなブックマークに追加
  • Pocket
  • LINEで送る

commentYour Message

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

checkboxみはら.comはエックスサーバーです

PAGE TOP arrowup